【实验名称】
如何配置路由器支持Telnet。
【实验目的】
掌握路由器的管理特性,学会配置路由器支持Telnet操作的相关语句。
【背景描述】
假设某学校的网络管理员第一次在设备机房对路由器进行了初次配置后,他希望以后在办公室或出差时也可以对设备进行远程管理,现要在路由器上做适当配置,使他可以实现这一愿望。
本实验以1台R1762路由器为例,路由器命名为RouterA。1台PC机通过串口连接到路由器的控制(Console)端口,通过网卡(NIC)连接到路由器的fastethernet0端口。假设PC机的IP地址为192.168.0.137,配置路由器的fastethernet0端口的IP地址为192.168.0.138,子网络掩码都是255.255.255.0。
【技术原理】
路由器的管理方式可分为两种:带内管理和带外管理。通过路由器的Console口管理交换机属于带外管理,不占用交换机的网络接口,特点是线缆特殊,需要近距离配置。第一次必须利用Console配置路由器,使其支持telnet远程管理。telnet指路由器的网络接口,连接到网络中的某台主机。利用这台主机进行远程管理和配置,特点是网管可以进行远程控制。路由器出厂情况下没有配置支持远程登录的。
【实现功能】
使网络管理员可以通过Telnet对路由器进行远程管理。
【实验设备】
R1762(1台)、PC(1台)、直连线(1条)
【实验拓扑】

【实验步骤】

步骤1.        在路由器上配置fastethernet1/0端口的IP地址。
Red-Giant>enable                             !进入特权模式
Red-Giant # configure terminal                !进入全局配置模式
Red-Giant (config)# hostname RouterA         !配置路由器名称为RouterA
RouterA(config-if)# interface fastethernet1/0      !进入路由器接口配置模式
RouterA(config-if)# ip address 192.168.0.138 255.255.255.0   !配置路由器管理接口IP地址
RouterA(config-if)# no shutdown              !开启路由器fastethernet0接口

验证测试:验证路由器接口fastethernet1/0的IP地址已经配置和开启。

RouterA#show  ip  interface fastethernet1/0
  FastEthernet 1/0
  IP interface state is: UP
  IP interface type is: BROADCAST
  IP interface MTU is: 1500
  IP address is:
    192.168.0.138/24 (primary)
  IP address negotiate is: OFF
  Forward direct-boardcast is: ON
  ICMP mask reply is: ON
  Send ICMP redirect is: ON
  Send ICMP unreachabled is: ON
  DHCP relay is: OFF
  Fast switch is: ON
  Route horizontal-split is: ON
  Help address is: 0.0.0.0
  Proxy ARP is: ON
  Outgoing access list is not set.
  Inbound access list is not set.
RouterA#show ip interface brief
                          !验证接口fastethernet1/0的IP地址已经配置和开启
Interface                   IP-Address(Pri)      OK?       Status
serial 1/2                  no address           YES       DOWN
serial 1/3                  no address           YES       DOWN
FastEthernet 1/0       192.168.0.138/24        YES       UP
FastEthernet 1/1           no address           YES       DOWN
Null 0                       no address           YES       UP

步骤2.        配置路由器远程登录密码。

RouterA(config)# line vty 0 4           !进入路由器线路配置模式
RouterA(config-line)# login             !配置远程登录
RouterA(config-line)# password star      !设置路由器远程登录密码为star
RouterA(config-line)#end

验证测试:验证从PC机可以通过网线远程登录到路由器上。

C:\>telnet 192.168.0.138     !从PC机登录到路由器上

步骤3.        配置路由器特权模式密码。

RouterA(config)# enable secret star       !设置路由器特权模式密码为star
或者:
RouterA(config)# enable password  star

验证测试:验证从PC机通过网线远程登录到路由器上后可以进入特权模式。
C:\>telnet 192.168.0.138     !从PC机登录到路由器上

步骤4.        保存在路由器上所做的配置。

RouterA# copy  running-config startup-config         ! 保存路由器配置
或者:
RouterA# write memory

验证测试:验证路由器配置已保存。

RouterA#show startup-config
version 8.32(building 53)
hostname RouterA
enable secret 5 $1$yLhr$4tvyAFDzpz4ywypr
!
interface serial 1/2
clock rate 64000
!
interface serial 1/3
clock rate 64000
!
interface FastEthernet 1/0
duplex auto
speed auto
!
interface FastEthernet 1/1
duplex auto
speed auto
!
interface Null 0
!
line con 0
line aux 0
line vty 0
login
password 7 0133574225
line vty 1
login
password 7 093c011335
line vty 2
login
password 7 1006062617
line vty 3
login
password 7 025057360a
line vty 4
login
password 7 08103b1400
!
end

【注意事项】
路由器接口缺省是关闭的(shutdown),因此必须在配置接口fastethernet0的IP地址后须用命令no shutdown开启该接口。
【参考配置】

RouterA#show running-config                   !显示路由器RouterA的全部配置
Building configuration...
Current configuration : 666 bytes
!
version 8.32(building 53)
hostname RouterA
enable secret 5 $1$yLhr$4tvyAFDzpz4ywypr
!
interface serial 1/2
clock rate 64000
!
interface serial 1/3
clock rate 64000
!
interface FastEthernet 1/0
ip address 192.168.0.138 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet 1/1
duplex auto
speed auto
!
interface N
interface N
!
line con 0
line aux 0
line vty 0
login
password 7 08103b1400
line vty 1
login
password 7 14015e0c33
line vty 2
login
password 7 0350231914
line vty 3
login
password 7 1316064b1f
line vty 4
login
password 7 08103b1400
!
end