实验名称

重叠地址转换

实验目的

掌握当外网与内网有重叠地址时的重叠地址转换技术。

背景描述

你是某集团公司的高级网络管理员,你的分公司员工向你反映了一个情况,他要访问公司的文件服务器却无法实现,通过查询,你获知该员工的内部IP地址和公司的文件服务器的IP地址一样,而员工访问文件服务器是通过该服务器的主机名访问的,员工并不知道此情况,因为大部分员工使用正常,所以你不能改动文件服务器的地址请你给予解决。

实现功能

当内部本地地址和外部发生重叠时,将外部全局地址转换为外部本地地址。

实验拓扑

实验设备

R2624(2台)

实验步骤

第一步: 基本配置

Red-Giant>enable                                    
Red-Giant#configure terminal                                                                                    
Red-Giant(config)#hostname R1                             
R1(config)#interface serial 0                             
R1(config-if)#ip address 195.1.1.4 255.255.255.0                                                
R1(config-if)#clock rate 64000                              
R1(config-if)#no sh                   
R1(config-if)#exi                 
R1(config)#interface fastethernet 0                                   
R1(config-if)#ip address 10.1.1.5 255.255.255.0                                               
R1(config-if)#no sh                   
R1(config-if)#end                 
Red-Giant#configure terminal
Red-Giant(config)#hostname R2
R2(config)#interface serial 0
R2(config-if)#ip address 195.1.1.10 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exi
R2(config)#interface fastethernet 0
R2(config-if)#ip address 152.1.1.1 255.255.255.0
R2(config-if)#end

验证测试:

R2#ping 195.1.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echoes to 195.1.1.4, timeout is 2 seconds:
!!!!!

第二步:配置重叠地址转换

R1(config)#access-list 1 permit 10.1.1.1                                        
R1(config)#ip nat pool globalpool 195.1.1.1 195.1.1.3 netmask 255.255.255.0  ///定义可用的内部全局地址                                                                                                     
R1(config)#ip nat inside source list 1 pool globalpool overload
!定义内部本地地址与内部全局地址的转换                                                                                             
R1(config)#ip nat outside source static 10.1.1.1 2.2.2.2  ///定义从外部全局地址到外部本地地址的映射                                                        
R1(config)#interface fastethernet 0                                   
R1(config-if)#ip nat inside                           
R1(config-if)#exi                 
R1(config)#interface serial 0                             
R1(config-if)#ip nat outside                            
R1(config-if)#exi                 
R1(config)#ip route 152.1.1.1 255.255.255.0 serial 0                                                    
%Inconsistent address and mask                              
R1(config)#ip route 152.1.1.1 255.255.255.255 serial 0      

验证测试:

R1#sh ip nat translations 
Pro Inside global      Inside local       Outside local      Outside global
---195.1.1.1          	10.1.1.1      ---                ---
---                  ---                2.2.2.2           10.1.1.1

注意事项

  • 不要把inside和outside应用的接口弄错;
  • 要加上能使数据包向外转发的路由,比如默认路由或者静态路由。

参考配置

R1#sh run
Current configuration:
!
version 6.14(2)
!
hostname "R1"
!
ip subnet-zero
!
interface FastEthernet0
 ip address 10.1.1.5 255.255.255.0
 ip nat inside
!
interface FastEthernet1
 no ip address
 shutdown
!
interface FastEthernet2
no ip address
 shutdown
!
interface FastEthernet3
 no ip address
 shutdown
!
interface Serial0
 ip address 195.1.1.4 255.255.255.0
 ip nat outside
 clock rate 64000
!
interface Serial1
 no ip address
 shutdown
!
ip nat pool globalpool 195.1.1.1 195.1.1.3 netmask 255.255.255.0
ip nat inside source list 1 pool globalpool overload
ip nat outside source static 10.1.1.1 2.2.2.2
ip classless
ip route 152.1.1.1 255.255.255.255 Serial0
access-list 1 permit 10.1.1.1
!
line con 0
line aux 0
line vty 0 4
 login
!
end